Browser Compatibility for Blackboard Learn

For Blackboard Learn, it is strongly recommended that students and instructors use:

1. The latest non-beta version of Mozilla Firefox for PC and/or Mac computers as it is the most compatible with our Blackboard Learn system.

2. The latest version of Chrome is also a good choice.

While Internet Explorer 8, 9 and 10 are listed as being compatible, there are many common issues being reported due to using IE with Compatibility Mode turned on. If you are going to use IE for Blackboard Learn, please make sure to turn off Compatibility Mode.

(Click the Compatibility View button imagethat appears next to the Address bar.)